You also cannot simply say "--update-with-dependencies", since the version resolution will complain about this long before the dependencies starts to upgrade.The solution to this problem is to update core and symfony at the same time.

problems with abx guide updating-49problems with abx guide updating-40

- Can only install one of: symfony/class-loader[v3.4.2, v3.2.14].

- Can only install one of: symfony/class-loader[v3.4.3, v3.2.14].

You see, if you run composer update with no arguments, *all* of your dependencies will be attempted to be upgraded.

Which might by pure coincidence be what you want, but for me it was not the case. So my recommendation is to not run composer update with no arguments, unless you are 100% sure you know what this does, and you know this is what you want to do.

Problem 1 - Installation request for symfony/yaml (locked at v3.2.14, required as ~3.2.8) -If you delete the lock file then you could just as well do a full composer update, should result in the same.

This is really more of a drupal-composer issue than drupal core as all the problems here are due to additional dependencies (for example because of drupal/console depending on symfony/config or drupal-core-require-dev).

- Conclusion: remove symfony/class-loader v3.2.14 - Conclusion: don't install symfony/class-loader v3.2.14 - drupal/core 8.5.0-beta1 requires symfony/class-loader ~3.4.0 - satisfiable by symfony/class-loader[3.4.x-dev, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.2, v3.4.3, v3.4.4].

- Can only install one of: symfony/class-loader[3.4.x-dev, v3.2.14].

- Can only install one of: symfony/class-loader[v3.4.0-BETA2, v3.2.14].

- Can only install one of: symfony/class-loader[v3.4.0-BETA3, v3.2.14].

So in theory you could say update drupal/core , but since so many of them rely on symfony/config, this simple command fixed it for me: The problem of upgrading here, is somewhat of a catch 22.